Configuring Reporting Service Add-in for sharepoint - HTTP status 401: Unauthorized.
I have the following setup Machine 1 WSS 3.0 Installed Reporting Service Add-in Machine 2 Reporting Service Sharepoint Object Model SQL Server Sharepoint and Report Server DB I have congigured Reporting Service for Sharepoint Integrated Mode adn Created new Reprot Server DB Sahre Point Integration is Green and verified link In Sharepoint Central Administration Manage Reporting Service Integratio i have selected the URL and "Trusted Account" as my web applications use "Windows Integration - NTLM". All services, DB access everything running under one domain user account. I am logged into sharepoint with same account. When clieck on set server defaults i get following error An unexpected error occurred while connecting to the report server. Verify that the report server is available and configured for SharePoint integrated mode. --> Server was unable to process request. ---> The request failed with HTTP status 401: Unauthorized. Same error when i try to add a report to a sharepoint webapplication The domain account is part of "Farm Administration", "site colletion administrato" and local administrator also on both servers. Can someone let me know how to fix this.
March 22nd, 2007 11:29am

Problem solved by ssetting cscript adsutil.vbs set w3svc/NTAuthenticationProviders "NTLM"
Free Windows Admin Tool Kit Click here and download it now
March 22nd, 2007 12:01pm

Thanks for the help Ganesh, that worked for me also.... K
March 28th, 2007 3:36pm

We have a similar problem. Where abouts in the file are you putting cscript adsutil.vbs set w3svc/NTAuthenticationProviders "NTLM"? Thanks Andrew
Free Windows Admin Tool Kit Click here and download it now
August 2nd, 2007 5:56pm

Thanks a lot! It's great!!!
October 10th, 2007 6:23pm

In case you hadn't figured it out... you don't put that in the file. You just run the command from the command prompt from the directory where the file is located. Mine was in \inetpub\adminscripts This worked for me! I was getting ready to call Microsoft support. Thanks for saving me the time and money!!!
Free Windows Admin Tool Kit Click here and download it now
February 28th, 2008 6:30pm

Thank you Ganesh, You saved my day....your solution worked for me. Thank you very much
June 21st, 2008 9:08pm

What is you really want to use Kerberos?
Free Windows Admin Tool Kit Click here and download it now
June 24th, 2008 8:27pm

I believe this KB article has the answer:
July 1st, 2008 4:35pm

jpmartop,were you able to get this to work?We have a 4 server topolgy.mosswfesqlssrsand are using Kerberos.I've installed the wfe on the ssrs and am using a domain user for services, web and pools. I get all green dots in the ssrs config. in Central Admin, Grant access seems to work with the domain user, but set defaults gives me:HTTP status 401: Unauthorized. What should my web security on the default web site and reports and reports server look like? Integrated SecurityShould the SSRS WFE entry in MOSS have Web application service turned on?I've checked that my SPNs are good.I've installed sql server sp2 and a did windows update on all servers..Could it be the user I log into the Central Admin with.. it's got server administrator and Farm administrator?Thanks for any help or information.
Free Windows Admin Tool Kit Click here and download it now
September 13th, 2008 7:42pm

Hi JCNET,I don't know what do you mean by WFE. In my particular situation I was able to put it all to work, but only inside the same network... Is this your situation?All the security for the web sites shoud be Windows Authentication, that a recall, and I advise you to run all the services from WSS to SSRS with the same user (domain administrator - just for debug porpouses).Good luck,jpmartopP.S. I ended up using https and basic authentication, but Microsoft ended up providing me for a special update for reporting services...
September 13th, 2008 7:51pm

thank u Ganesh,I got the same problem,now i have resolved it.
Free Windows Admin Tool Kit Click here and download it now
June 4th, 2009 6:27am

I'm having the same problem, did you ever get a resolution to this issue?
July 16th, 2010 8:37pm

Hey JCNET, Did u ever find a solution for your issue? Thanks
Free Windows Admin Tool Kit Click here and download it now
January 10th, 2011 5:34pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics