Client need to open auditing reports in excel application not in browser
Good day,I encountered with this issue in MOSS 2007. Auditing reports was opened from common SharePoint auditing page.This page contains hyperlinks to auditing reports.When any user tries to open this hyperlink, "open file" dialog does not appear, instead of this a IE browser silently open in text XML format.I suppose that common behaviour is when user open a hyperlink, report will open with excel application through "open file" dialog. For example, hyperlink in SharePoint contains URL:javascript:SubmitFormToRunReport('8a061723-2fe4-42a8-9adf-3db17430902d','\u0025D0\u00259F\u0025D0\u0025B0\u0025D1\u002580\u0025D0\u0025B0\u0025D0\u0025BC\u0025D0\u0025B5\u0025D1\u002582\u0025D1\u002580\u0025D1\u00258B_\u0025D0\u0025B0\u0025D1\u002583\u0025D0\u0025B4\u0025D0\u0025B8\u0025D1\u002582\u0025D0\u0025B0.xml','');How to change this behaviour, when reports are open with excel app and eliminate IE browser opening? Any workaround will help. Thanks.
January 29th, 2010 12:03pm

Hi, Based on my test, it is most probably due to the fact that Excel is missing on your machine.In this case, auditing report will be open as XML instead of displaying properly in Excel. Hope it can be helpful to you.Lily Wu
Free Windows Admin Tool Kit Click here and download it now
February 1st, 2010 10:13am

I have the exact same problem -- and I definitely have Excel on my machine. XML files in other libraries open in Excel perfectly. The Audit Logs are opening in browser mode and are unusable without saving locally. Because in SharePoint 2007 the only way to trim contents from a site collection's audit file is through this report, this means that audit files can grow unmanageable. (Audit files for a site collection are stored in the same content DB and add to the site's storage needs.) Trying to troubleshoot, in SharePoint at the library level you can configure to require files to be opened with an application rather than a browser. However, this can't be set for the area where Audit Logs are stored. We need a way to correct this. Thank you!
October 7th, 2010 4:58am

Same problem here...would love a resolution. Started happening for me when I "upgraded" to Office 2010. Run report, xml opens in browser, I have to save locally, then open with Excel. As often as I use auditing, it is a serious productivity drain.
Free Windows Admin Tool Kit Click here and download it now
October 25th, 2010 7:21pm

This is a horrible answer and, clearly, not the issue. I have the same issue and it started occurring after I upgraded to Office 2010.
November 12th, 2010 11:33am

I confirm you that this issue doesn't solved on our desktops. Good news is after we migrate on SP2010, this issue is vanished.
Free Windows Admin Tool Kit Click here and download it now
December 17th, 2010 7:08am

Any resolution to this? I have a user on IE 7 under XP with the same issue. Only she is not given the option to save the file, it just opens in IE. We are good 10 months away from going to 2010. Thanks.
January 5th, 2011 5:25pm

I had the same problem after my computer had to be changed to a new domain. I also couldn't upload multiple files anymore. I tried a couple of things, not sure which worked or if both did, but here they are: 1. Word 2007 / Word Options / Trust Center / Trust Center Settings / I added the Sharepoint sites that I use to Trusted Locations along with their subfolders ( I had to check "Allow Trusted Locations on my network (not recommended) so it's your call. 2. Under Word Options / Resources / run Microsoft Office Diagnostics / Diagnose - this ran and found one issue. After this point I was able to upload multiple files and when I selected an audit report I would receive the popup asking if I wanted to open or save. Open worked with Excel perfectly. Hope this helps.
Free Windows Admin Tool Kit Click here and download it now
April 7th, 2011 3:24pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics