Central Administration shows error 26 - A network-related or instance-specific error occurred while establishing a connection to SQL Server


i Follow this Article to Config FBA , BUT after Step 3 , My Central Administration shows an Error : 

 A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 Error Locating Server/Instance Specified)

Correlation ID: 89651359-9c57-4241-8254-eb3be052c4f0

Now , i cannot access to my Central Admin Setting , but my site Collections works well....

i Rollback  all setting but  no Effect !!!!!

i execute iisreset but nothing !!!!

what should i do?

please help me.. Thanks in Advanced


When i was checking EventViewer , i saw an Event log    :

The Forefront Identity Manager Service cannot connect to the SQL Database Server. The SQL Server could not be contacted. The connection failure may be due to a network failure, firewall configuration error, or other connection issue. Additionally, the SQL Server connection information could be configured incorrectly. Verify that the SQL Server is reachable from the Forefront Identity Manager Service computer. Ensure that SQL Server is running, that the network connection is active, and that the firewall is configured properly. Last, verify the connection information has been configured properly. This configuration is stored in the Windows Registry.

Is there any relation between this message And my Problem!!!???
  • Edited by MBS220 Wednesday, June 06, 2012 8:22 AM
June 1st, 2012 6:58am

Does the account you are using to configure FBA has sufficient privileges ?

Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2012 9:54am

i Use Administrator Role of Domain..  

June 2nd, 2012 10:38am

Have a look at this blog post

Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2012 12:10pm

Did you make any changes to the web.config for Central Administration? I guess you want FBA on one of your web applications. Is that correct?
June 2nd, 2012 2:39pm

if you see this Article  that i follow for FBA , i choosed Central Administration Web App to Config  the Provider & ... . this means all changes (i did in IIS) apply on Web.config

Yes Correct but through IIS Setting 

(sorry about my English Lang.)

Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2012 2:54pm

in the blog post you sent has written : Error from the Browser : Cannot connect to the configuration database.

i tested My Configuration DataBase Connection String in Registry & i have no problem about it.

my CA page load successfully BUT my links does not works !!!

(sorry about my English Lang.)

June 2nd, 2012 2:58pm

Hi MBS220

In the past, I came across an ambiguous network issue on SQL Server and it made SharePoint couldn't connect to configuration database, AdminContent Database.

  • SQL Server is not ready to accept new client connections. Wait a few minutes before trying again.
  • A network-related or instance-specific occurred while establishing a connection to SQL Server.

I fixed completely within 10 minutes by auditing Event Log and SQL Services. You need to do the following, in my experience:

  • Check SQL Service account and make sure that account is correct, or if anything has changed due to Active Directory, you need to re-assign SQL service account again.
  • Check SQL server connection and make sure you have checked "Allow remote connection to this server" in case you have deployed SharePoint in terms of n-tier farm.
  • Check network card driver and make sure your network card driver is updated latest version.
  • Restart SQL Services.

It worked well after that but I was still worrying some stuffs.

Please read below paragraph carefully:

"The client sends a UDP packet to SQL Browser on the target machine. When the named instance is on a windows cluster, the packet is sent to the cluster IP(or more specifically, the IP address corresponding to the virtual SQL Server). However, SQL Browser is not cluster-aware and listens on IP ANY. When SQL Browser receives the UDP request packet, it sends a response UDP packet back the client. The destination IP address is the client's IP address, however, the source IP address is changed. It's now the IP address for the NIC card on the physical machine, rather than the virtual SQL Server IP address. The source IP address of the response UDP packet is determined by Windows OS, based on the routing table. Because both virtual SQL Server IP address and the IP address attached to physical NIC are usually on the same subnet (thus belong to same route), physical IP address is selected preferably. Depends on the security settings on the client and server machines, this response UDP packet may be dropped because the peer IP address is changed. We have been seeing that the response  packet is dropped by Firewall and/or IPSec."

- Source: Unable to connect to a SQL Server named instance on a cluster

Maybe built-in firewall, which was Windows Firewall with Advanced Security in Windows Server 2008, didnt drop the packet. However, I worried that Astaro firewall put in my corporate network firewall might drop the packet or something that it prevented packet from port 1433 that was default port on SQL Server. In addition, I didnt know exactly if there was any IPSec but I also worried that IPsec might also drop the packet if IPsec policy was enabled on the client and it couldnt establish a trust connection between the client and server.

So you need to analyze and audit carefully if your environment has any security devices.



Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2012 3:39pm

hi Mr Thuan Soldier

i checked some of your Solution like SQLService (Was OK) , Allow Remote connection (was OK & has check mark), Restart SqlService (Done Successfully),  Network Card Driver (my Connection is OK) before , but didnot check SQL Service account & i will do Soon,


i did not any changes on Firewall or IP ... i change IIS setting (through  this Article ) ,

Do these settings have any effect on IP or  firewall ?



June 2nd, 2012 3:59pm

Check your windows firewall setting on sql server. You might need to allow 1432..1433 ports.


Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2012 4:28pm

Hi MBS220,

Let's try to use Ping command from SharePoint application server to Database server and then see how it goes. If you get Request time out, you need to carefully check all firewalls put in your corporate infrastructure.


June 3rd, 2012 9:45am


The port 1433 is Enable in SQLserver config mngr .(TCP/IP)

Free Windows Admin Tool Kit Click here and download it now
June 6th, 2012 6:37am


what does it mean (from Sharepoint APP Server to Db Server ?!!!)

i did not understand?

Is your mean this Command :  ping [MY_DOMAIN_IP]  

if yes , it's OK & works well 

June 6th, 2012 6:41am


i checked it & it's Enable & OK...  (like image  above)

i have no problem with my IP (my CA site  is loaded Successfully & my site collection is running well & mYDomain is Working well But My CA Links like Manage web applications does not work

Free Windows Admin Tool Kit Click here and download it now
June 6th, 2012 6:56am


i checked my Sql Service Account & it's (like other) Local System Account

June 6th, 2012 7:15am

i find the answer :::

Solution : 

1- Open SharePoint Central Administration v4 Web.config File in VS2010 or notepad

2- Find this Node :

    <roleManager enabled="true">

(Under System.Web Node)

& Change Enabled to  false

& Now My CA works Well   :-)

(i hope works other days too !! )

Thanks you Guys for your Helps

Free Windows Admin Tool Kit Click here and download it now
June 6th, 2012 8:45am

Hey this is nice solution it worked for me

I used the above approach,

Scenario :CA is working well but Other links like Web Applications ,Create Site Collections won't open.

If  Forms Based Authencation is set in Central Administration 's web.config this issue will raised

March 12th, 2014 11:38am

This worked for me - thank you so much - I had spent a few frustrating hours trying to track down the solution before I found this.
Free Windows Admin Tool Kit Click here and download it now
November 28th, 2014 4:50am

Thank you so much, i fixed my issue following your solution
June 5th, 2015 10:14am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics