CcmSetup failed with error code 0x80070643

I have an xp sp3 machine that client push is failing on.  I have used wbemtest to confirm that wmi is working and accessible to the network access account.  I would like to ru ccmclean on the machine, but it's a laptop with an user logged on, so that is always a bit tricky. I did run it using psexec and the /q switch, but the exe just sat as a running process for 45 mins and nothing appeared to happen. I have disabled the xp firewall service.  Below are the last few lines of the ccmsetup log:

File C:\WINDOWS\ccmsetup\MicrosoftPolicyPlatformSetup.msi installation failed. Error text: ExitCode: 1603
InstallFromManifest failed 0x80070643
Sending Fallback Status Point message to 'CKTSCCM02.CDS.INT', STATEID='311'.
Failed to get client version for sending messages to FSP. Error 0x80041013
Params to send FSP message '5.0.7804.1300 Deployment Error 0x80070643. Pre-req: MicrosoftPolicyPlatformSetup.msi. ExitCode: 1603 Action:  ErrorMessages: '
State message with TopicType 800 and TopicId {9BAA09F2-B5D1-4C8B-9AD0-1D6DE9D0E850} has been sent to the FSP
CcmSetup failed with error code 0x80070643

September 24th, 2013 8:18pm

The network access account is not used with client push. It's the client push account or the computer account of the site server though.
Examine client.msi.log instead of ccmsetup.log. No need to post the entire log. The problem should be listed right above the occurance of "return value 3".
Free Windows Admin Tool Kit Click here and download it now
September 24th, 2013 8:41pm

Also check MicrosoftPolicyPlatformSetup.msi.log (in c:\Windows\ccmsetup\logs) as it appears that's what's specifically dying.
September 24th, 2013 9:41pm

There does not seem to be a client.msi.log in the ccmsetup folder.   Here are the relevant portions of the policyplatformsetup.msi.log:

CAQuietExec:  MOF file has been successfully parsed
CAQuietExec:  Storing data in the repository...
CAQuietExec:  An error occurred while processing item 1 defined on lines 19 - 22 in file C:\Program Files\Microsoft Policy Platform\SchemaNamespaces.mof:
CAQuietExec:  0X80041002 Class, instance, or property 'Name' was not found.
CAQuietExec:  Error 0x80070003: Command line returned an error.
CAQuietExec:  Error 0x80070003: CAQuietExec Failed

UPDATE: I fixed it by doing a winmgmt /resetrepository

  • Edited by dpmaker Wednesday, September 25, 2013 3:48 PM
  • Marked as answer by dpmaker Wednesday, September 25, 2013 3:56 PM
Free Windows Admin Tool Kit Click here and download it now
September 25th, 2013 1:00pm

Hi Guy's,

as the command mention above didn't work i found another solution:

net stop winmgmt

Under C:\Windows\System32\wbem rename the repository folder to repository.old

net start winmgmt

fixed the Problem for me


November 26th, 2014 10:21am

That's generally a bad thing to do as its destructive. There are other and better ways to repair WMI starting with Vista.
Free Windows Admin Tool Kit Click here and download it now
November 26th, 2014 3:06pm

I was unable to uninstall SCCM on a Windows 7 Enterprise, SP1 machine.  CCMSetup.log showed "CCMSetup failed with error code0x80070643" and I got a dialogue that said, "There was a problem starting PolicyAgentEndpoint.dll. The specified procedure could not be found."  I found another webpage that said, for a completely different error message, to run Regsvr32 ATL.dll.  I tried it and it resolved the dialogue regarding PolicyAgentEndpoint.dll.  Strange, but good enough.  Then I found this thread and ran Winmgmt /resetrepository and after that, CCMSetup /Uninstall worked.  Thanks fo
April 23rd, 2015 2:19pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics