Cannot connect to Reporting Services in SSMS using Servername
Hi, Kindly help me as i can't connect to Reporting Services in SSMS using SERVERNAME but using URL(http://localhost/ReportServer) I can connect. Here is the error I received. Please advice. TITLE: Connect to Server ------------------------------ Cannot connect to PERRYDUNDOC-W7. ------------------------------ ADDITIONAL INFORMATION: Unable to connect to the server at SERVERNAME. The specified URL might not be valid or there might be a problem with the report server version or configuration. Specify a different URL, or contact your server administrator to verify that the report server runs SQL Server 2008 or later. Additionally, if you are trying to connect to a SharePoint-integrated report server, verify that SharePoint is installed on the server and that the report server uses SharePoint integrated mode. (Microsoft.SqlServer.Management.UI.RSClient) ------------------------------ BUTTONS: OK ------------------------------ Thanks, Perry
September 27th, 2010 2:27am

Hi Perry, By default, the SQL Server Manager Studio(SSMS) uses the following way to connect to a report server instance: Parse the server name(we typed) to get the ReportServer URL. This step uses the SQL Server Reporting Services(SSRS) WMI provider to get the URL. Use the got URL to connect to the report server. There is a little different between the returned URL and the URL you used(http://localhost/ReportServer). The returned URL should be: http://<machinename>/ReportServer. This URL is same to the URL we can get from the "Web Service URL" in the Reporting Services Configuration Manager. In this case, in order to troublehshoot the issue, please make sure we can open the report server by using http://<machinename>/ReportServer (from Internet Explorer). If so, we may be able to connect to the report server by using the server name too. However, if we are not able to connect to the report server, please check the authentication configuration settings. If we are using Kerberos authentication, please make sure the Service Principal Name(SPN)s are registered correctly. If you have any more questions, please feel free to ask. Thanks, Jin Chen Jin Chen - MSFT
Free Windows Admin Tool Kit Click here and download it now
September 29th, 2010 8:21am

Hi Jin Chen, I able to connect using the following in IE. 1) http://<machinename>/ReportServer 2) http://localhost/ReportServer can you please help me on this --> please check the authentication configuration settings. If we are using Kerberos authentication, please make sure the Service Principal Name(SPN)s are registered correctly. Thanks, Perry
September 29th, 2010 9:34am

Hi Perry, Do you use a proxy in the network? This means configuring the machine to use a proxy to access the network. Thanks, Jin ChenJin Chen - MSFT
Free Windows Admin Tool Kit Click here and download it now
September 29th, 2010 9:56am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics