Cannot Reconnect to Stand-Alone WSS 3.0 Install/Databases
I have a stand-alone WSS 3.0 installation (single server, Windows internal database) to which I am unable to reconnect using the SharePoint Configuration Wizard. The install was working fine until I attempted to install the Oct 2009 Cumulative Update - the installed failed a number of times and I tried re-running the wizard during that time until I finally got the update to install (that problem is detailed here in case it is important).Basically, I think that during the time I was troubleshooting the failed update I somehow disconnected from the config/content databases when running the configuration wizard and now I cannot reconnect. The most recent issue is that when I ran the wizard it indicated that I was connected to "Unknown" and so I chose to disconnect (which was successful). The next time I ran the wizard, expecting to have a choice to reconnect and select the database, the wizard proceeded to try to reinstall completely, creating a new config database, etc. And then the configuration failed (because there is already a central admin website in IIS), so that's where I am stuck.I have tried to connect to the existing configuration database using the stsadm command line utility with no luck so far. The command I am using is:psconfig.exe -cmd configdb -connect -server webserv\microsoft##ssee -database SharePoint_Config_c2389660-34fa-4d6a-b1df-1d08ea28a68dThe error returned is The server parameter specified with the configdb command is invalid. Failed to connect to the existing server farm located at the specified database server and database name. The database name is not a valid configuration database.I think this is the correct config database as I can connect to the sql instance of the Windows internal database using SQL Server Management Studio Express and see this listed. The only other databases are an AdminContent database, Content database and Search database. If I try to specify user credentials the error returned states that basically the Network Service is assumed for stand-alone installations.Can anyone tell me the correct procedure for reconnecting to an existing WSS stand-alone install using either the config wizard or the stsadm command line tool? Thanks in advance,Chanda
February 22nd, 2010 12:03am

Hi CHanda,Sounds like the config db is probably corrupt, As long as you know the names of your Content Dbs, and any additional Solutions, or Features that may have been installed1. Backup All of the Dbs through SQL Studio Manager2. Run SharePoint Products and Technologies Configuration Wizard, Stand Alone Installation3. Install any of the Features, Solutions that were installed previously4. Restore the ContentDB from the Backup5. Find the the Content DB that is hosting your Web Application SharePoint - 80: Central Administration > Application Management > Content Databases6. Remove the ContentDb from the SharePoint 80 WebApplication and Add the retsored ContentDb to the Web Application7. Add Any host hedaers that you may have been using on the IIS WebSite8. IISResetYou should be able to test your webApps now.You may want to run if you have errors in the event log with profile sync. However, lets get the WebApps back up first...stsadm -o sync -listolddatabases 3 to get a list of GUIDs for using prepare to movestsadm -o preparetomove -site "http://MyUrl" -oldcontentdb GUIDCheers,-Ivan Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
Free Windows Admin Tool Kit Click here and download it now
February 22nd, 2010 1:54am

Ivan,Thanks for your post - I followed your instructions and with a slight modification I was able to get my WSS 3.0 install back up and running. The only addition step I had to take was in between removing the default content db and adding the restored content db (your step 6 above). I was able to remove the default content db that had been created for the web app successfully, however when I attempted to add my restored content db I received the following message: Attaching this database requires upgrade, which could time out the browser session. You must use the STSADM command 'addcontentdb' to attach this database.I found a related article here that explains why I was getting this and how to use the command: http://support.microsoft.com/kb/926961. When I ran the stsadm command as described it appeared to successfully add the content db, however when I browsed my site I got a "connection closed" message.I was finally able to get things working by running the psconfig command to force the upgrade AFTER I had removed the default content db, but BEFORE I attached the restored content db. The command to force the upgrade (since my original upgrade didn't seem to actually finish) was psconfig -cmd upgrade -force -inplace v2v -wait. Then when I attached my restored content db I think the upgrade actually took place (before I don't think it upgraded correctly because I already had the content db attached).Anyway, just wanted to say thanks and respond with my notes in case anyone else has the problem.Chanda
February 27th, 2010 9:32pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics