Cannot Edit the Managed MetaData Tags within the properties of a document within a Document Library

Hi All,

I have a site that I have backed up from our SharePoint 2013DEV server and restored into our SharePoint 2013 Test server using backup-spsite and restore-spsite. The site in question has a document library, with documents that have tags that are pulled down from the Managed MetaData Service application (Which was also taken from Dev and imported into Test).

Originally, when the site was moved, the tags were not showing at all. I managed to get these to show by granting all users Read permission to the TaxonomyHiddenList located at http://domainname/Lists/TaxonomyHiddenList/AllItems.aspx
A user noticed that once they checked out a document, they weren't able to amend the Tags on the documents. The button to choose metadata is just unclickable. I've granted all users full permission to the list(Not recommended I know, but just for testing) I've also granted all users Full permission to the Managed Metadata Service application for testing but still no luck.

Thanks in advanced for any suggestions!


May 29th, 2015 10:14am

Hi lemington,

Please test on another site, check whether this issue occurs.

You meantioned that the button to choose metadata is just unclickable, where is the button

Please provide a screenshot about your issue, it will make others in the forum easy to find a solution for you.

In addition, if one user checks out a document, other users cannot edit the document untill the user checks in this document. So, for the checking-out document, please check in it firstly, then try to modify the tags.

Thanks,

Wendy

Free Windows Admin Tool Kit Click here and download it now
June 1st, 2015 3:10am

Here is the location of the error. The buttons next to the classification for the document (That comes from the Managed metadata service) aren't clickable.

Thanks



June 2nd, 2015 3:05pm

Hi lemington,

From your screenshot, I understand that you could not edit the managed metadata column, is it right?

I want to know which term set you used in the managed metadata column, and was the term set from global term set or site collection local term set?

If it used the site collection local term set, how did you move it from Dev server to Test server?

Per my knowledge, when we moved the managed metadata service application, only global term set can be migrated well and local term set may not work well.

Please create a new managed metadata column using the same term set, then test again, compare the result.

Thanks,

Wendy

Free Windows Admin Tool Kit Click here and download it now
June 3rd, 2015 10:13pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics