Can't install .NET Framework 3.5 Features

Hi everyone,

When installing .NET Framework 3.5, I get the following error message:

Has anyone had the same error?


May 31st, 2013 4:20pm

.NET 3.5 is different from other features.  Its files are not included with a normal installation.  There, you have to specify a location for the installation files or have the machine connected to the internet so it can reach Microsoft and download the files.  The files are located in the \sources\sxs folder on the distribution media.  There is an option when selecting to add this feature to include an alternate destination from which to obtain the files.

Free Windows Admin Tool Kit Click here and download it now
May 31st, 2013 7:40pm

Thanks Tim. I've sorted it out following your recommendation. Windows Server 2012 generally hosts .NET Framework 4.5 so we have to re-allocate source path if we want to add .NET Framework 3.5 for installing something (e.g. SQL Server 2008).
June 1st, 2013 4:44am

I've had this issue also. How did you "re-allocate the source patch" to allow you to install 3.5?
Free Windows Admin Tool Kit Click here and download it now
July 12th, 2013 10:15am

Hi dude -d,

You need to manually install it because its not automatically installed during Windows Server 2012 installation. Use the following command:

$path = "H:\sources\sxs"


Note: The DVD source of Windows Server 2012 has to be mapped. In my case, H (yours may be D by default) is the name of the DVD volume and the folder sources\sxs includes many components and packages. One of them is .NET Framework 3.5.


July 12th, 2013 10:18am

Thanks Thuan. Got my hands on a DVD. Done now.
Free Windows Admin Tool Kit Click here and download it now
July 12th, 2013 2:22pm

Would you please advise how you made it, because i got $path is not recognized and can't install .Net Framework 3.5 until now
February 1st, 2014 10:05am

Hi Hisham, You need to use Windows PowerShell to use the command. Insert Windows Server 2012 DVD to check the path of .NET 3.5 Framework installation source. It's sources\sxs by default. You should be able to find it in the DVD. Feel free to shoot me an email at if you still can't install it. Regards, -T.s
Free Windows Admin Tool Kit Click here and download it now
February 1st, 2014 11:19am

If you need to build many servers this might come in handy. The post describes how to integrate .net 3.5 into a OSD task sequence

February 1st, 2014 12:43pm

I tried every suggestion here
and elsewhere. I found the solution on someone's blog. Check to see if
you have the either or both of the following windows updates installed
and uninstall them. Once I uninstalled them, I was able to install .Net
3.5 on server 2012 using the server manager, power shell, or the
command line.

Remove KB2769166 & KB2966827

  • Proposed as answer by razorbakill Wednesday, September 17, 2014 1:57 PM
Free Windows Admin Tool Kit Click here and download it now
September 17th, 2014 1:56pm

Ding ding! We have a winner! After trying all the suggestions here, DISM, the Powershell command, and multiple installation media, razorbakill has a working solution. Uninstalled KB2966827 and ran the install through Powershell using...

Install-WindowsFeature name NET-Framework-Core source <drive>:\sources\sxs\

Installation was a success! However, Powershell did not immediately report that it had succeeded. But if you run Get-WindowsFeature you will see it is installed.

Happy hunting for bonked updates! Once again, Microsoft: Stop breaking your own OS's functionality with updates.

  • Edited by G.Clayton Thursday, September 18, 2014 5:35 AM
September 18th, 2014 5:33am


Thank you, been scratching my head for a couple of hours.

Free Windows Admin Tool Kit Click here and download it now
September 18th, 2014 11:54am

The Oscar goes to razorbakill!

Removed KB2966827, put the DVD in, ran the Server Manager Feature Installer, set the source to <DVD:>/sources/sxs -> installs flawlessly.


September 19th, 2014 8:50pm

I've been beating on this problem myself for several days.  I have an identical server that I've installed at a customer's location that seems to be working fine, the one in my office that I purchased and installed at the same time isn't working! 

The alternate source wouldn't work. The "go to windows update" in group policy to disable WSUS as a source . . . didn't work.  Running DISM from the command line didn't work.  It wouldn't even allow me to go to without a 404 error.  Dim bulb finally started to glow faintly . . . I had my server set up to update itself from WSUS via group policy setting.  I disabled that GP link and voila! I could install features. 

Just checked on customer Group Policies on identical server that has been working fine . . . their server is has a GPO linked to the server that sets up WSUS for their server. So why does that one work and not mine?  Something different, but somehow related to WSUS and updates (at least in my "testing").

See for those procedures that didn't work for me but did for others.

  • Edited by pcsdpolsen Monday, September 29, 2014 10:32 PM more info
  • Proposed as answer by Max Wat Thursday, February 26, 2015 10:53 PM
Free Windows Admin Tool Kit Click here and download it now
September 29th, 2014 10:21pm

Thanks razorbakill, for me the offending update was KB2966828. I also had to install .Net 3.5 via Powershell instead of Server Manager like G.Clayton did.

September 30th, 2014 3:20pm

i had the problem too, after uninstall KB2966828 the install of the DotNet Feature via powershell is succesfull.

Free Windows Admin Tool Kit Click here and download it now
October 8th, 2014 5:27pm

My problem was also KB2966828.

Ran from command line;

dism /online /enable-feature /featurename:NetFX3 /all /Source:<Drive Letter>:\sources\sxs /LimitAccess

Installed fine.

October 10th, 2014 5:59pm

For me, KB2966828 was also the guilty party.
Free Windows Admin Tool Kit Click here and download it now
October 14th, 2014 3:40pm


I would like to share my experience in this.

Just kick off security updates 2966827 and 2966828. Do the uninstall the things and reboot server.

Then go ahead and run the elevated cmd prompt, type below cmd and hit enter.

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All

Just make sure that you have connected to internet.

I have tried all the possibilities but finally i picked up this one. it works for me in windows server 2012.

I have extracted the above info from sources and



May 25th, 2015 3:33am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics