Can't deploy Report
When I try to debug or deploy, I get time out error or do I have "corect permissions to connect to report server" error. I have tried several various configuration in the config Manager and BIDS Project properties, but no luck An adventureworks fold was created on one attempt. But can't deploy report. I can connect to Web Service URL and Report Manager URL from Reporting Services Configuration Manager. I can also see data in report My System Windows XP Pro SP3 SQL Server 2008 R2 Configuration Manager Settings Service Account Network Service Web Service URL http://IBM-T42:8080/ReportServer (can connect from Config Mnager) Database Credential Service Account Login NT Authority\NetworkService Report Manager URL http://IBM-T42:8080/Reports (can Connect from Config Manager) Execution Account IBM-T42\Owner BIDS Project Properties Target Report Folder AdventureWorks Target Server URL http://ibm-t42:8080/ReportServer Please help, very frustrated. Thanks, Mike
October 24th, 2010 7:01pm

Hello Mike, Can you manuall upload the RDL file from Report Manager URL without errors?Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich tglich
Free Windows Admin Tool Kit Click here and download it now
October 25th, 2010 9:57pm

You need to ensure that the id that you are connecting to BIDS with has publisher or content manager permissions in RS. Also a timeout might indicate that you have a DNS problem. Try to change the deployment server to the IP. I have never used 8080 in these parameters either. As the other poster specified you can copy the RDL to the server and manually upload the report but I would only do that as a last resort. Regards, Susan
October 25th, 2010 10:54pm

Thanks for the sugestion Olaf, I guess the short answer is no. I can access Report Manager and upload page. I can open config manager without login, I can open the the Report Manager URL from the config manager without a login. When I try to upload file from Report Manager, I browse to the rdl file and hit ok. It takes a while, maybe a minute or two, but eventually I get a login dialog to connect to IBM-T42 (my computer name). I put no passwords on any accounts, so I do not enter any in dialog. I try Owner, but no luck. I try IBM-T42\ luck. I tried IBM-T42:8080/ luck. What should this login map to, the Service Account? The Execution Account? oocassionally I have no got login but black web page. Do you know why it asks me for login, I was already in Report Manger? Thanks again, any help is appreciated.
Free Windows Admin Tool Kit Click here and download it now
October 25th, 2010 11:28pm

Hi Computermike, I guess that either your rdl file exceeds 4M or insufficient permission to deploy the reprot. Here are some steps, for limit for the input stream buffering threshold, follow steps mentioned at . for insufficient permission,launch the BIDS using "Run as administrator", then try to deploy the report again. thanks, Jerry
October 26th, 2010 2:53am

Hey Jerry, thanks for the input. I tried to run as administator, but administator had no I added one and opened BIDS as Administrator. I could not log on to my dataabse with these credentials, a login opened and I accessed my database as "Owner" who is a computer admistrator. Not accessing database as administrator was weird. I changed the web.config files (maxRequestLength = "9000") for ReportManager and ReportServer following the steps in your post. I also added a "top 5" to my query in select statement to limit amount of data. When I deploy the operation times out. When I debug using the green play button "There were Build Errors, Continue? If I say no, I get Operation timed out if I say yes ReportServer opens, but my file can not be found. Could I be missing a driver or something?
Free Windows Admin Tool Kit Click here and download it now
October 26th, 2010 11:09am

Hi Susan, Thanks for the tips. I have tried uploading file manually, I get login and login as Administator but the Login just keeps popping up after a minute or so, it loops a few times and then gives me blank web page. I followed Jerry's tips and they did not help. I used 8080 because it default in when I installed. Can you tell me how to ensure the ID I am connecting to BIDS with has publisher and content manager permissions in RS. Not sure how to change deployment server to IP either. I am using Windows XP Pro SP3. Do you think I could be missing driver or something? I can see data in Bids
October 26th, 2010 11:21am

Also, The TargetFolder, "AdventureWorks" is created each time I deploy...if I deltete it first.
Free Windows Admin Tool Kit Click here and download it now
October 26th, 2010 11:27am

Also, The TargetFolder, "AdventureWorks" is created each time I deploy...if I deltete it first. But now, when I try to preview data it says login for IBM-T42\Administrator. Am trying to correct.
October 26th, 2010 11:37am

Hi Susan, In the SSRS 2008 R2 Configuration Manager, you have to use a TCP port in the URL, i.e. 8080. It will not let you add URL without one. I did try 80 but no luck there either. I am not using a DSN. Although I might check to see if I have the right SQL drivers. I think this is MicroSoft bug. It should not be this hard to configure. I deployed reports on 2005 a year and a half ago fine, no problems. I think it is problem between Windows XP Pro and SSRS 2008 R2. I wish someone from MicroSoft would comment. Or anyone who has gotten SSRS 2008 R2 to work on Windows XP Pro SP3. I suspect there are none.
Free Windows Admin Tool Kit Click here and download it now
October 27th, 2010 10:27am

=================================== Could not connect to the report server http://ibm-t42:8080/ReportServer. Verify that the TargetServerURL is valid and that you have the correct permissions to connect to the report server. (Microsoft SQL Server Report Designer) =================================== The operation has timed out (Microsoft.ReportingServices.Designer) ------------------------------ Program Location: at Microsoft.SqlServer.ReportingServices2010.RSConnection2010.SetConnectionProtocol() at Microsoft.SqlServer.ReportingServices2010.RSConnection2010.SoapMethodWrapper`1.ExecuteMethod(Boolean setConnectionProtocol) at Microsoft.SqlServer.ReportingServices2010.RSConnection2010.ListItemTypes() at ReportServiceClient2010.CheckAuthenticated() at Microsoft.ReportDesigner.Project.ReportClientManager.DetectEndpointAndAuthenticate(String url, ICredentials credentials, String& authCookieName, Cookie& authCookie, EndpointType& endpointType) at Microsoft.ReportDesigner.Project.ReportClientManager.DetectEndpointAndAuthenticate(String url, ConnectionProperties& connectionProperties) at Microsoft.ReportDesigner.Project.ReportClientManager.GetCredentials(String url, CancelFlag cancelFlag) at Microsoft.ReportDesigner.Project.ReportProjectDeployer.PrepareDeploy()
October 27th, 2010 10:44am

Any luck on this Computermike? I've read just over 20 posts and tried numerous things and cannot get it to deploy on test server (Windows 2003 R2 SP2), but it works fine on development machine (Windows 7). I posted a separate question so as to not derail yours if the problem is different ( Let me know if you found a fix.
Free Windows Admin Tool Kit Click here and download it now
November 14th, 2010 3:13pm

OK, I think figured it out. It only took me two months. I am working through a SSRS step by step book and am a newbie at SSRS. I was using an older IBM thinkpad running XP Pro as development enviorment. I reinstalled SQL Server 2008 cause I thought it might be an installation issue or something. I was having the same deployment problems. I started created a few new database and small tables with two rows in various databases, including AdventureWorks and writting reports from them. They always deployed. But the AdventureWorks Report from my Step by Step book would not deploy. I gradually increase the complexity of the query that worked to mirror the adventureWorks report, and eventually it failed to deploy too. I ran a report with three columns and 100 rows and it would deploy. I tried to grouped the report by one of the columns and it failed. I found at a certain point of complexity in the report, it hangs because my thinkpad doesn't have enough resources. Any thoughts? Thanks again to everyone who replied.
November 22nd, 2010 11:30am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics