Can't create a SQL Server package configuration
I've created the table [SSIS Configurations] and have added a dummy row to this with "XYZ" in the filter name. When I use the package configuration wizard I can see that offered as a filter - so I know my connection is seeing the server ok. The problem I get is when I get through to "Finish" and insert the configuration to the table - I get this error message and I can't find any help on it: Cannot insert configuration information into the configuration table. (Microsoft.DataTransformationServices.Wizards) Could not complete wizard actions. I'm connecting as system administrator and am just foxed as to why it won't insert ... Anyone got any pointers? Many thanks Matt
June 29th, 2006 1:33pm

have you used SQL Profiler to watch what is being sent to the server?
Free Windows Admin Tool Kit Click here and download it now
July 1st, 2006 10:06am

*bump* I am getting this error too. Any ideas? Nothing odd in profiler.
August 10th, 2007 7:21am

that is weird. If you are choosing a row that already exists in the configuration table; I think the wizard prompts you whether you wan to re-use the exiting row or you see that prompt? what are you selecting?
Free Windows Admin Tool Kit Click here and download it now
August 12th, 2007 12:17am

I've resolved my issue. It was to do with a property value (an SQL string) that was too long to fit in the default configuration table data column (254 characters.) I have moved to using an external xml file instead for the SQL statements. I also tried making the column larger, but ultimately I think the more appropriate option for us is going to be external xml files.
August 13th, 2007 1:33am

I know you got your problem solved, I was getting the same error but the problem was that someone added a primary key to the ConfigurationFilter column. They were creating separate Package Configurations for each value they wanted to make configurable. The true key would be ConfigurationFilter and PackagePath but that is too large for a primary key.But the important lesson from that is that this type of message is likely to result from a failure to insert a row into the SSIS Configurations table. This could be due to anything: column values that are too long (like the original issue on this thread), DDL issued on this table that conflict with it's use, such as adding an invalid primary key or maybe adding a non-nullable column.If you are running into this error, and have a testing environment I suggest creating the table from scratch by selecting the "new" button for the configuration table entry. If it doesn't fail with that new table, identify any table differences that exist between the those two tables. Columns, indexes, permissions, etc.
Free Windows Admin Tool Kit Click here and download it now
January 14th, 2009 2:40am

My problem was the field length. The configured value field was too small. I dropped the table, changed the field length and was fine. I had to recreate the data in the table too. CREATE TABLE [dbo].[SSISConfigurations]([ConfigurationFilter] [nvarchar](255) NOT NULL, [ConfiguredValue] [nvarchar] (500) NULL, [PackagePath] [nvarchar] (255) NOT NULL, [ConfiguredValueType] [nvarchar] (20) NOT NULL ) ON [PRIMARY] GO
October 30th, 2009 2:17am

Even I got the similar issue this noon. Initially I thought it is something to do with permission on the database or schema. As I am connecting to different domain through my BIDS 2008, however after going through the thread I realized it is nothing but the column length issue. ConfigurationFilter nvarchar no 510 ConfiguredValue nvarchar no 1000 PackagePath nvarchar no 510 ConfiguredValueType nvarchar no 40
Free Windows Admin Tool Kit Click here and download it now
July 27th, 2011 3:35pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics