Can't Open my Seagate 1tb external drive

Hi,   I can't seem to open my Seagate 1tb harddrive on my computer. It shows up in disk management but it won't be seen in my drives. i run windows 8 on a surface pro and it was recognized easily for the last few months with no problems, any help? i've tried uninstalling the driver and replugging it in buut does not work....

I plugged it into a TV yesterday to try to watch something on it in Japan but I'm scared I may have reformatted it or something as i can't read the remote of the TV properly. Would this be the problem?   any suggestions helpful!!!


December 31st, 2013 10:07am

What file system is used in your external hdd? Chances are that this file system is not readable in Windows operating system.

Use diskpart program to diagnose your hdd and reformat it

(Be aware that diskpart program is more powerfull than standard Disk Management can do.)



Free Windows Admin Tool Kit Click here and download it now
January 2nd, 2014 1:08pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics