BIDS Crashes after opening a Data Flow
I have a package with numerous data flows in it. (I know - this is not recommended as a best practice.) Anyway, one of the Data Flows just started giving me some trouble. When I opened that particular Data Flow, then BIDS would crash. I tried loading the project again, and opening that Data Flow task, and it just kept crashing. I rebooted - same deal. The Data Flow was itself very simple. There was an OLE DB Source, and OLE DB Destination, a conditional split, a derived column, a data conversion and a Lookup. Pretty routine stuff. Out of the blue really, and long after I created it - it just starting crashing BIDS when I opened it. My solution was to copy the Data Flow control flow component and paste it back into the same package. This worked perfectly fine, and didn't see any issues after. So, apparently something in the meta data became corrupt, and caused it to crash. Anyway, just curious if others have seen this behavior, but also wanted to post this as a solution in case someone else has the same problem.
March 11th, 2008 9:50pm

have u Installed last sp of visual studio?
Free Windows Admin Tool Kit Click here and download it now
March 11th, 2008 10:45pm

I'm running 05 SP2.
March 11th, 2008 11:46pm

I had the same issue using BIDS with Visual Studio 2008. The copy/paste method worked like a charm to fix the problem, but it would be nice to know why it happened in the first place.
Free Windows Admin Tool Kit Click here and download it now
July 21st, 2011 9:49am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics