App-V package won't start


Today a package that has been working fine will no longer start. Client version is 5 SP1. Looking at the logs below it looks like a permissions issue?

Event ID:      14021
Task Category: Streaming
Level:         Error
Keywords:      Streaming
User:          SYSTEM
Content required by an application could not be retrieved from the network. A request for file C:\App-V Packages\25BE10A3-32EE-4941-A894-4AF9B96B8EF2\E07A140F-18AF-44B3-97FA-267DB75A42AA\Root\swcli7.exe from package version {00000000-0000-0000-0000-000000000000} failed with error Access is denied..  Check your network connection and try again.

Event ID:      14023
Task Category: Streaming
Level:         Information
Keywords:      Streaming
User:          SYSTEM
A request for the file C:\App-V Packages\25BE10A3-32EE-4941-A894-4AF9B96B8EF2\E07A140F-18AF-44B3-97FA-267DB75A42AA\Root\swcli7.exe from process 0x464 is being processed as SYSTEM since no suitable user token could be found.



January 13th, 2014 2:22pm


Is the package cached locally ? If not, try to cache everything locally

Does both the user and the computer account have access to the package where it is set to stream from?

Free Windows Admin Tool Kit Click here and download it now
January 13th, 2014 2:30pm

Package is deployed via SCCM 2012 and is set to "download content from disirbution point and run locally".

January 13th, 2014 2:49pm


Yes, that is a setting that you configure within the application model.

Unfortunately that setting does not tell the state of this specific package on this specific client.

If you run the following powershell commands;

set-executionpolicy remotesignyed

import-module appvclient


Is the specific package, which you are experiencing problems with, fully cached on the client?

Free Windows Admin Tool Kit Click here and download it now
January 13th, 2014 2:51pm

Was this problem solved?

I am getting "SYSTEM since no suitable user token could be found." error.

This happens with every app-v packages on the computer.

If I open cmd.exe inside the package I can start programs like notepad etc. If i try to start program that is set as virtual application it don't start. I have set iexplore.exe as virtual application in one package and there i am unable start it. In another package i can start iexplore.exe inside package.

Tested with App-V Client 5.0 sp2 and sp2 hotfix 5

November 7th, 2014 3:32pm

I recommend to open a new thread as your problem seems to have another error message/characteristics as the original one
Free Windows Admin Tool Kit Click here and download it now
November 7th, 2014 5:34pm

Hi guys

I'm getting the same error with App-V Client 5.0 SP3

didn't understand from this thread what exactly I need to check

many clients have this error. when I check it locally on my machine I have 4 packages published to my user

after a logon - I have like 15 error messages of: Event ID: 14021 on files from 2 out of 4 of my packages.

when I run Get-AppVClientPackage I see the 4 of the packages and all with 0 percentloaded

I must add I use a full App-V infrastructure environment and we're using SharedContentStore


July 19th, 2015 3:39am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics