Anonymous access not working properly
I have configured anonymous access for my site, actually a month or so ago. I got everything in IIS and Central Admin and my site was working beautifully. Somehow I am no longer able to access the anonymous settings from the permissions drop down inSite Settings > Modify All Site Settings > Advanced Permissions.I double checked Central Admin and IIS this morning and it is all setup for anonymous properly. I can navigate manually to /_layouts/setanon.aspx, it is all grayed out, but the entire site radio button is checked. So at least I know it's enabled for the site. Anonymous users can still see the site.The site is also a forms based auth site.However, I have some lists on the top level that are being access by custom web parts that are now breaking. When I try to access the anonymous settings for the lists, the option is not in the drop down there either. So I break inheritance, still nothing there. I can manually navigate to the setanon page for the list, but all those settings are unchecked and grayed out. So I know it is not enabled on the lists, which is causing me all kinds of problems in my custom web parts. I don't know what has caused this. Which is not near as important as fixing it at this point.Other than the setting in IIS and Central Admin, I don't know where else to look to make sure it is enabled. My only other thought is that the Content DB is somehow corrupted for that setting. Everything else is working fine on the site. Anyone have any ideas? Thanks.
June 17th, 2008 4:19pm

This isn't a programming question which is why you've had no replies. Moving it to the Admin forum which should help.
Free Windows Admin Tool Kit Click here and download it now
June 17th, 2008 6:40pm

Gotcha. Thanks, much appreciated.
June 17th, 2008 6:43pm

Hi Joe, Did you ever manage to resolve this issue? I'm having the same problem!Any advice you can offer would be great!
Free Windows Admin Tool Kit Click here and download it now
August 20th, 2008 5:54pm

One thing you may want to check is the Policies for the Web Application in Central Admin. Make sure there are no policies there that might interfere with anonymous access. For example settings that deny access to a web application may require authentication to occur in order to enforce the Deny. Not sure if this is the issue but it is something to check none the less.
August 20th, 2008 9:02pm

I had a similar problem. We have a Windows 2008 server with IIS7.My anonymous access did not work. setanon.aspx boxes were greyed-out when logged into the extended forms site with a forms user having full control rights - as James said earlier (Policies for Web Application in Central Admin).The reason why the anonymous access options were not showing in my case was that I was browsing using an Alternate Access Mapping (AAM) other than the one the site was initially created on.What I did to fix this was to browse to the forms site on the original address that was specified when the site was extended.My result is that the Anonymous Access option is now visible in the Advanced Permissions > Settings menu and I could check the 'Entire site' radio button. It is not greyed out anymore.There is no reason why the Anonymous Access option should not be available in other AAMs set up on an extended forms site. I'm not sure if this bug lies in IIS7 or SharePoint (???), since I read another post here saying that renaming a site in IIS7 caused the same issue. Program You
Free Windows Admin Tool Kit Click here and download it now
February 12th, 2010 5:47pm

Thanks Goodmedalist, logging on via the original ip/port used in the site configuration (versus the external pointing one added later) solved my issue as well.
May 12th, 2010 2:19am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics