After applying SP2 to WSS 3.0 environment, can not add users from a trusted domain
We have a WSS 3.0 environment on our DMZ We have a one way trust between our internal domain TT and external domain clients. So we were always able to add internal domain users to our SharePoint sites using TT\loginName Yesteday we applied SP2 for WSS3 and this functionality stopped working. When we try to add any new TT users to the site collection, I get an error "No Exact Match was found." But the current TT users are able to get in to the site and work fine. I searched on internet and found that I need to run stsadm coomands for the peoplepicker to work with trusted domains. So we rebuilt the trust between domains. Then I ran following commands on the SharePoint frontend server: stsadm.exe -o setapppassword –password somekey stsadm.exe –o setproperty –pn peoplepicker-searchadforests –pv domain:tt.local,ADUser,passwordforADuser Then ran IISRESET But still when I try to add users and type TT\sucheta.patil on the Add Users page, I get error "No exact match was found." Any ideas? Any help would be greatly appreciated..
October 14th, 2010 8:57pm

according to technet article, you need to add the URL also in your command. http://technet.microsoft.com/en-us/library/cc263460%28office.12%29.aspx check the example at the end of the post: " Specify user account and password from a one way trust To specify the user name and password from a one-way trust, so that People Picker can look up this information, use the following syntax: stsadm -o setproperty -url http://<server:port> -pn peoplepicker-searchadforests -pv "forest:contoso.corp.com, <LoginName>, <Password>;domain:bar.contoso.corp.com, <LoginName>, <Password>" " hope this help thanks -ws SharePoint administrator, MCTS,MCITP
Free Windows Admin Tool Kit Click here and download it now
October 14th, 2010 11:43pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics