Adding machine through computer association after SP2 upgrade PXE ISSUE
Here is the excerpt from the log. MAC=00:24:E8:CE:F6:97 SMBIOS GUID=4C4C4544-0047-3010-8034-B6C04F314C31 > Device not found in the database. smspxe 11/11/2009 8:31:10 AM 8080 (0x1F90) Notice the time on the entry (8:31am) and result (Device not found in the database) Below is a snapshot of the computer object from your collection. Notice the creation time (8:35am) For some reason, I dont know why (because Im not there) there is a time difference of when you added the object and when it showed up in the database. Could be the UI, or the use of a remote console. I would suspect the later. You see the insertion of a computer association object is a direct add to the target collection, not the all systems collection. For some reason the WDS PXE boot queries a table that the object has not yet populated, resulting in the time disparity. I would update the collections node in the UI and upon that check the creation time in the all systems collection for that object. Once that is complete you should be able to PXE boot the box.This is a response I gave as a workaround for an Issue I'm seeing across our entire SCCM environment.What puzzles me is that before the sp2 upgrade all was well.The last admin that responded was using the remote admin UI.I am gathering more information to narrow down what is going on here.What isalso strange:I assumethat since the object is not registered to the database andPXE responds with "not found",that once it is registered the machine should boot.... What does happen is that the machine wont boot until WDS has been recycled. Any ideas or a fix would be great.Dan Passionate about SCCM
November 12th, 2009 1:23pm

verify that the computer object isn't marked as obsolete in the All Systems collectionmy SCCM step by step Guides > http://www.windows-noob.com/forums/index.php?showtopic=1064
Free Windows Admin Tool Kit Click here and download it now
November 12th, 2009 1:32pm

Niall,As I stated before this is a new machine object added through computer association, and never existed in the environment.I can't even imagine how it would be marked as obsolete.For some reasona new computerobject added to a target collection that has an advertisement assignedis a direct add, and should be picked up by PXE / WDS to run.What does happen is that once the machine is PXE booted after adding the object through computer associations it reports that it is not found in the database.Upon verifying that it is in the database .... at least from the UI aspect.... it still wont PXE boot.Only after WDS have been recycled and making no changes to the object will it PXE boot.Thus my dilemma.The only thing I have to go on is the time of creation is older than the first PXE boot.DanPassionate about SCCM
November 12th, 2009 2:08pm

Did you check the box for unknown computer support under PXE Service Point? What account are you using for the PXE Point Account Connection?
Free Windows Admin Tool Kit Click here and download it now
November 12th, 2009 4:10pm

Helix2301,I'm running SCCM 2007 sp2.I think thats afeature thatonly can beenabled in R2.I may be wrong on that though.No account is needed for PXE that I know of with this version.As far as the MP I'm using the computer account.No password set on the PXE service point.Thanks for the responce.DanPassionate about SCCM
November 12th, 2009 4:34pm

I see the where you are talking about on the PSP account info.It is the default machine account to connect to the DB.Passionate about SCCM
Free Windows Admin Tool Kit Click here and download it now
November 12th, 2009 4:42pm

Does that account have permission to write to the database?
November 13th, 2009 11:58am

YesThis is a production environment which has been working for over a year with RTM, and 6 months with SP1. It's just been since the sp2 upgrade that we've experienced issues with the delay in computer objects no populating in the database and PXE. I am going to go out on a limb here and make an observation. 1. When using the remote admin UI to add a new computer through Computer Association the object is displayed in the target collection. 2. Upon PXE booting the machine the response from the PXE service point is with the correct MAC address "Device not found in the database". (smspxe.log) 3. Upon subsequent PXE boots we no longer see the MAC but do see MAC=FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF "Device not found in the database". 4. PXE has cached the machines MAC and will no longer attempt to PXE boot. 5. The time of the machine objects Creation date/time from the PXE boot is later (This varies from 10 to 30min) 6. After stopping and starting the WDS service on the respective server, the Machine will PXE boot and all is well. Very much a pain.... Thanks, Dan Passionate about SCCM
Free Windows Admin Tool Kit Click here and download it now
November 13th, 2009 1:30pm

Have you checked the date and time in the bios on the computers you are trying to pxe?
November 13th, 2009 1:53pm

Also try Re-importing your PXE Cert that might help.
Free Windows Admin Tool Kit Click here and download it now
November 13th, 2009 1:55pm

ok to answer your questions:1. No... but as we speak am setting up to roll out another machine.2. Created new PXE certs for all servers couple days ago.For this test I will:1. Create an machine object through Computer Association2. Verify it's in the target collection3. UpdateCollection Membership onCollections node in the UI4. Verify Machine object in in and time/date is current4. PXE boot the machine Will send resultsThanks,DanPassionate about SCCM
November 13th, 2009 2:50pm

Here are the results of the test:What's happening is:If a new machine, out of the box, and has notbeen added to the SCCM environment, is PXE booted (Administrators get the MAC by pausing at the PXE boot screen) themachine throws an entry into the smspxe.log like:**** NOTE ****IP addressin the log entries belowwere replaced by xxx[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 73abbcExecuting LookupDevice(4C4C4544-0046-3010-8034-B7C04F314C31, 00:24:E8:CF:F8:30)CDatabaseProxy :: LookupDevice succeeded: 0 0 0 0MAC=00:24:E8:CF:F8:30 SMBIOS GUID=4C4C4544-0046-3010-8034-B7C04F314C31 > Device not found in the database.After seeing this I had the admin PXE boot two more times and observed the log entries of:[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 73fd4csmspxe11/13/2009 12:07:50 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 740d9csmspxe11/13/2009 12:07:52 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 741decsmspxe11/13/2009 12:07:56 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 742e3csmspxe11/13/2009 12:08:04 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 743e8csmspxe11/13/2009 12:08:54 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 744edcsmspxe11/13/2009 12:08:56 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 745f2csmspxe11/13/2009 12:09:00 PM5544 (0x15A8)[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 746f7csmspxe11/13/2009 12:09:08 PM5544 (0x15A8)No more log entries1. Stopped and started the WDS service2. had him import the machine3. verify that the machine object was there4. PXE bootAfter that it worked fine.On conclution:If a machine is not in the SCCM environment PXE/WDS does not handle the PXE request right.Executing LookupDevice(4C4C4544-0046-3010-8034-B7C04F314C31, 00:24:E8:CF:F8:30)CDatabaseProxy :: LookupDevice succeeded: 0 0 5630 1MAC=00:24:E8:CF:F8:30 SMBIOS GUID=4C4C4544-0046-3010-8034-B7C04F314C31 > Device found in the database. MacCount=1 GuidCount=0[xxx.xxx.xxx.xxx:67] Recv From:[000.000.000.000:68] Len:548 73ecfcIgnoring req from [000.000.000.000:68] Dest Server:[xxx.xxx.xxx.xxx][xxx.xxx.xxx.xxx:4011] Recv From:[xxx.xxx.xxx.xxx:68] Len:548 26891dc[xxx.xxx.xxx.xxx:4011] Recv From:[xxx.xxx.xxx.xxx:68] Len:303 268a294Executing GetBootAction(5630, SERVER-NAME) vLastPXEAdvertisementID is NULLvLastPXEAdvertisementTime is NULLGetBootAction: MAC:00:24:E8:CF:F8:30 SMBIOS: SMSID:GUID:1568A62B-A683-4C47-B0D0-D9DF29F2D713 LastAdv:This is what is expected.Waiting for ideas.Thanks,DanPassionate about SCCM
Free Windows Admin Tool Kit Click here and download it now
November 13th, 2009 3:48pm

I have seen this before, and given your workaround (restarting wds) figure it is not a strict sccm issue.I think wds somehow caches the request, the fact that you pause pxe is more or less responsible for this.I am pretty sure that if you would add the mac address directly before the first boot that the pxe boot would work fine.How to get the mac address without pausing and before the pxe boot is another story however."Everyone is an expert at something" Kim Oppalfens Configmgr expert for lack of any other expertise. http://www.scug.be/blogs/sccm
November 13th, 2009 4:17pm

Just for testing purposes did you try creating a boot cd and see if you can image off that.
Free Windows Admin Tool Kit Click here and download it now
November 15th, 2009 2:58pm

did you update the dp's with the latest version of your boot images AFTER you upgraded to SP2 ? and, is MDT used in your sccm environment ?my SCCM step by step Guides > http://www.windows-noob.com/forums/index.php?showtopic=1064
November 15th, 2009 3:33pm

I think wds somehow caches the request That's true. See also http://support.microsoft.com/kb/969113/EN-US
Free Windows Admin Tool Kit Click here and download it now
November 16th, 2009 3:10am

Thanks Kim,I am with you on that, but what bothers me is the fact that all was working well before I applied service pack 2.Since I'm not running version R2 (which supports unknown machines), is there a possibility that some how PXE has marked it as discovered and assigned.I understand that there is no unknown collection which to assign to, and not an associated advert.I do have one more variable to throw into the mix....I am usingthe boot image created from the Central site which does not have a PXE Service Point site roll.This has been updated as per prereq requirements and all DP's have beenrefreshed with the updated Boot Image.Yes all works well and PXE boots fine when the machine entry is added before a PXE boot is initiated. Should I try and remove the PSP site roll from one of the site servers and reinstall?Thanks for the helpPassionate about SCCM
November 16th, 2009 10:37am

DP's were updated and no MDTPassionate about SCCM
Free Windows Admin Tool Kit Click here and download it now
November 16th, 2009 10:38am

Torsten,I wonder ifSP2 didn't take as it relates to PXE and kb969113.I can test that scenario by:1.PXE booting the machine2. adding the machine entry3. waiting one hour (I'll give it an hour and a half)4 PXE booting the boxWould be nice to know if it is a MOF entry on the timing issue or something simple to check.Kerwin you still around and watching???Thanks again,DanPassionate about SCCM
November 16th, 2009 10:49am

Torsten,I discovered an oddity.I know I've seen this in other posts but didn't connect the dots.Looks to be an SCCM issue or using SCCM at least there is a way to work around it without recycling WDS.If after encountering this issue you clear the last PXE advertisement on the consol (even though there is not an advert present in the dialog) it will PXE boot.At first I thought it could be the one hour time delay on WDS, but after getting frustratedwith not getting anywhere cleared thelast PXE advert on the object I was working on.....AND IT WORKED.....I applied this workaround to 4 more Machine objects exhibiting the same symptoms and dog gone itworked again.It is strange that thesmspxe.log didn'treflect as being already run.These machines were fresh systemsright out of the box.Ok Dev or Sustain engineering time for a fix...DanPassionate about SCCM
Free Windows Admin Tool Kit Click here and download it now
November 18th, 2009 10:25am

Is there anything new on this side. I have the same problem here.Newly import computer will not be able to boot on the PXE until I restart the service on the PXE server.I am doing my test on my secondary site at the moment.Mathieu
February 25th, 2010 12:11pm

Sorry Mathieu, Nothing new to report.Still exists in our environment at all locations (Primary, & Secondary).I guess it's not important enough of an issue to address.The cost to fix must be too great.All in all the overall product is outstanding.DanPassionate about SCCM
Free Windows Admin Tool Kit Click here and download it now
February 25th, 2010 4:26pm

The change in behavior from SP1 to SP2 was due to the understanding of the setting under the cache value in the registry. Torsten did mentionned this in that post http://social.technet.microsoft.com/Forums/en-US/configmgrosd/thread/8779e322-e973-4461-955e-9edf464ccb9e The value is stored in HKLM\Software\Microsoft\SMS\PXE\CacheExpire. Keep in mind that the behavior is different depending on the hotfix/SP level. kb969113: 0 --> 60s SP2: 0 --> 3600s
April 26th, 2012 3:25pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics