Adding dynamic images to a report - not working
Hello, I am trying to display an image based on the value of the product ID. So, external image Expression: ="file://V:\imagelocation\" + fields!imageid.value + ".jpg" If I put in the value directly it pulls the file from the location. So, what am I doing wrong? Or is this just not possible. TIA Jeff
November 7th, 2012 8:58am

Jeff We use in our application Dim FileImage As String = "file:" & GeneralParams.PersonalPicPath & EmployeeNo & ".jpg" Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/ MS SQL optimization: MS SQL Development and Optimization MS SQL Blog: Large scale of database and data cleansing MS SQL Consultants: Improves MS SQL Database Performance
Free Windows Admin Tool Kit Click here and download it now
November 7th, 2012 9:28am

Uri, Thanks, that helped a lot. I switched the + for & .. bingo. My next roadblock was that it works in development but not deployment. I have the images on a file server. Do I need to give special permissions for the reporting server on those folders? thanks J
November 7th, 2012 10:29am

Yep, sure, members of the windows group you gave access to run reports must have permission to the folder where the images are located. What error are you getting?Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/ MS SQL optimization: MS SQL Development and Optimization MS SQL Blog: Large scale of database and data cleansing MS SQL Consultants: Improves MS SQL Database Performance
Free Windows Admin Tool Kit Click here and download it now
November 7th, 2012 10:32am

Uri, There wasn't an error - just no image, but I added the Execution account from the report server and bingo part II; I have images off a file server. Time for a celebratory diet coke :-) thanks again Jeff
November 7th, 2012 10:57am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics