A large number of clients dont run task sequence, while other ones do run without problems
The following situation: - SCCM 2007 SP2 - 30 clients wich are advertised to run a OSD task sequence at the same time (nightly). - All those clients in the same subnet and boundary When the advertisement runs, 10 - 15 computers runs the task sequence without any problems. The others dont start the task sequence and their message logs say Error Message 10051: "The content for "EDE00299" - "1" could not be located. This SMS client will no longer attempt to locate this content. Possible cause: The content source might not be available on any distribution servers, or the advertisement may have been marked not to run program when no local Distribution Point is available and this SMS client is in remote roaming boundaries of the site. Content source might not be available because the advertisement is configured with the option Run program from distribution point on one or more branch distribution points and is not available on a standard distribution point. Branch distribution points do not support advertisements that are configured with the option Run program from distribution point. Solution: Use the Manage Distribution Points wizard to distribute the content to a distribution point. If this SMS client is expected to stay in remote roaming binderies then change the advertisement to allow running program from remote Distribution Point. Use the Manage Distribution Points wizard to distribute the content to a standard distribution point if you want to use the option Run program from distribution point." "EDE00299" is the ID of the task sequence itself. I searched for this problem and found things about 'boundarys' or 'disitrbution points not updated' But all clients al in the same boundary. And if the distribution points are not updated, it would affect all clients is my idea... Another strange thing: Its always the same clients who failed.. I run this advertisement on a weekly schedule, and now after 3 weeks, it are always the same clients wich doenst work. Boundary network connection is set to 'Fast (LAN)' What to check or what can be causing this problem
April 13th, 2012 7:33am

I would also advise you to have a good look at your boundaries. Are you using subnet or Active Directory boundaries? Are you using protected DP's for the boundaries? Are you looking at smsts.log? Usually the smsts.log located at X:\Windows\Temp\SMSTSLOG during installation can give you a good idea of what package is missing and if there doesn't seem to be a local DP. What IP does the DP have. What IP does a client that do work have? What IP does a client which doesn't work have? //update Is the task sequence a mandatory or optional advertisement? Website: www.danielclasson.com | LinkedIn: Daniel Classon
Free Windows Admin Tool Kit Click here and download it now
April 13th, 2012 7:39am

The task sequence is mandatory We use no protected DP's We use subnet boundaries like: Site: Ede type: IP subnet Connection: Fast Site: Ede type: IP subnet Connection: Fast And we have 1 AD boundary: DEFAULT-FIRST-SITE-NAME Site: Ede Type: Active Directory Site Connection: Fast IP adres of the DP: Ip adres of a client that works: Ip adres of a client that dont work: So both in same subnet, same boundary. I can't look in the smstslog right now, because the mandatory advertisement runs at night, and then im not able to control that ;-)
April 13th, 2012 7:58am

are switches or network equipment involved in the clients that don't work ? can you grab a smsts.log file from a failed system and post the relevant bits here please ? it'll be present on the computer if it (the ts) starts in windows Step by Step ConfigMgr 2007 Guides | Step by Step ConfigMgr 2012 Guides | I'm on Twitter > ncbrady
Free Windows Admin Tool Kit Click here and download it now
April 13th, 2012 6:04pm

What do you mean with switches or network equipment involved? All systems are connected to edge switches. I did a little test last weekend. Normally the TS starts in Windows. Once in a week on a mandatory schedule. As a test on a couple of failed clients, I did run a TS from PXE boot. They run it all without any problems. I hoped that maybe this should fix the problem with the scheduled TS wich starts in Windows, but it didnt. Just nothing happened. I can't post an smsts.log here, because they aren't present. Oh yes they are, but its from a date weeks ago, the last time that the TS runs succesfully on that machine.. So wich logs else could i check for this problem?
April 16th, 2012 2:55am

I figured something out about Boundarys.. Now we have Boundaries defined for all of our subnets like: Boundary: Site: Ede Type: IP Subnet Description: PC Lokalen Connection: Fast But we also have 1 AD Boundary defined: Boundary: DEFAULT-FIRST-SITE-NAME Site: Ede Type: Active Directory Site Description: Default-First-Site-Name Connection: Fast But maybe the problem is that in our AD environment, the site name 'Default-first-site-name' doesnt excist. Our AD site name is 'EDE' So there's a difference.. Strange thing here is that nothing has changed in that since all was set up couple of years ago, and evrything worked without any problems till couple of weeks ago.. Only thing that changed is that couple of weeks ago our clients (and so images and task sequences) are change from Windows XP to Windows 7. Maybe Windows 7 is more critical in the boundary things?
Free Windows Admin Tool Kit Click here and download it now
April 18th, 2012 4:57am

You can use IP subnets only for boundaries. I would try to run the task sequence through Run Advertised Programs and see what error comes up. Sometimes you get a message that some other advertisement is already running and that would cause it not run. Sometiems I restart systems before I run anything mandatory, doesn't always work but does for the most part.
April 18th, 2012 5:00pm

Ok i changed the AD site boundary so it matched the name in AD sites en services, but it didnt help. I got it to run from RAP and it runs succesfully.. No issues.. Here's a thing.. The advertisement is set to run as a mandatory advertisement with a weekly schedule. But that didnt work good, so also i did set a maintenance window on the collection. Also weekly at the same time. This have been worked for months.. Till we got WIndows 7 on our clients. From that moment we got many obsolete records so I set something up with merging obsolete records wich worked out fine.. The problem now is that almost all systems did run the task sequence once (3 weeks ago), and after that they dont run it anymore. But other clients in the same collection and the same subnet did run the advertisement every week fine.. At the failed clients sometimes the message is: "No maintenance window available" (but is still is..) On other machines the message is: "No content available"
Free Windows Admin Tool Kit Click here and download it now
April 19th, 2012 4:14am

Please check if there are duplicate GUIDs. Duplicate GUIDs? Fix it with Scripts! Sabrina TechNet Community Support
April 19th, 2012 5:18am

If you mean the "Computers that may share the same SMS Unique ID".. thats empty..
Free Windows Admin Tool Kit Click here and download it now
April 19th, 2012 6:01am

I did a new test on 15 clients in a classroom wich had these problems.. All clients are in the same subnet and behind the same switch. I made a new mandatory assignment in the task sequence advertisement, to run it once at 3:55pm The results: 1 client runs the advertisement succesfully.. But this particular client did run all weeks before without any problems On 4 clients nothing happened. And the advertisement state says as last: 15:55:01 Waiting for Content Strange thing is here in de cas.log: Location update from LS for content EDE0027A.3 and location request {8036B6CA-FF7F-404C-BA60-1DC8E307617F} ContentAccess 19-4-2012 16:51:20 1752 (0x06D8) No matching DP Location found ContentAccess 19-4-2012 16:51:20 1752 (0x06D8) This is 1 package in the task sequence. For all other packages it could successfully find the DP location. And then the other 10 clients. There nothing happened and the last advertisement state is at 3:15am (wich is the start time for the weekly mandatory assignment): Waiting for content For that clients i looked into the execmgr.log and saw the following at time 15:55: CExecutionManager::HandleMessage received message: '<?xml version='1.0' ?> <SoftwareDeploymentMessage MessageType='Execution'> <AdvertisementID>EDE20337</AdvertisementID> <PackageID>EDE00299</PackageID> <ProgramID>*</ProgramID> <HistoryLocation>Machine</HistoryLocation> </SoftwareDeploymentMessage>' execmgr 19-4-2012 15:55:00 2552 (0x09F8) Execution message received for user Machine execmgr 19-4-2012 15:55:00 2552 (0x09F8) Mandatory execution requested for program * and advertisement EDE20337 execmgr 19-4-2012 15:55:00 2552 (0x09F8) Creating mandatory request for advert EDE20337, program *, package EDE00299 execmgr 19-4-2012 15:55:00 2552 (0x09F8) A duplicate execution request is found for program * execmgr 19-4-2012 15:55:00 2552 (0x09F8) For this clients it looks like theyre waiting for another (the weekly) assignment to run? So for tonight another classroom is scheduled to go. I will remove all existing mandatory advertisements and set a new one up for that one. And tommorow look what happened..
April 19th, 2012 11:17am

Here's another update.. I did found out that the clients with status "waiting for content" all had the same entrys in the cas.log, the ones mentioned above "Location update from LS for content EDE0027A.3 and ......" and "No matching DP location found" The task sequence consist of a couple of packages. One of them is EDE0027A.3 (version 3). But at the moment the version is 4 because its updates 2 weeks ago. All clients (working and not working) are using the same advertisement and task sequence. But some clients are still "searching" for old versions of the package. The advertisement is set to "Run directly from distribution point". This is all working fine.. But why are clients searching for outdated package version in the task sequence? Work around will be to complete remove the advertisement and make a new one i guess. But how could i avoid this problem in the future?
Free Windows Admin Tool Kit Click here and download it now
April 20th, 2012 4:37am

I have run into the task sequence versioning issue as well. It seems to happen when the task sequence is updated after the clients recieve the policy (advertisement). I have had some luck flushing the policy with PolSpy and letting the client retrieve the new one. Have you compared the DP settings in clispy between broken and working systems? It almost sounds like the broken systems are pointing to a different DP than the working ones. Maybe you have conflicting boundery settings. I have seen this when AD bounderies and IP Subnet bounderies are both configured and don't match. When booted to media the systems work as expected because there is no AD association, but try in the full OS, and the process fails like you are describing (can't find content). Have you tried setting the advertisement options to get content from remote DPs and/or DPs outside the protected boundery?
May 14th, 2012 11:33am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics