ASP.NET Forms in SharePoint 2010 Windows Authorization Issues

Hello,

Recently created a a simple ASP.NET form using Visual Studio 2010.  The SharePoint 2010 development platform is single server based upon Windows Server 2008R2.

When I try to debug the app I get several FailedReqLogFiles which appear to be related to windows authorization. The first error is:

ModuleName: IIS Web Core

Notification: 2

HttpStatus: 401.2

HttpReason: Unauthorized

HttpSubStatus: 2

ErrorCode: 2147942405

ConfigExceptionInfo

Notification: AUTHENTICATE_REQUEST

ErrorCode: Access is denied. (0x80070005)

The second error message is a WindowsAuthenticationModule 401.1 and the third error message is a ManagedPipelineHandler 500 message.

I've been over the application pool settings, applicationHost.config, web.config files and all seems to be well. All settings reflect Windows Authorization settings and I'm logged into the server as a Admin.

Any suggestions on what might be causing the authorization problems would be greatly appreciated. Googling the errors has not helped.

Thank you, Alex

May 18th, 2015 9:14pm

Hi Alex,

For this issue, I recommend to enable anonymous authentication in IIS to see how it works.

You can use fiddler to track the request when accessing the form to see what the error is for the response.

Please also check ULS log for more error message.

Thanks,

Victoria

Free Windows Admin Tool Kit Click here and download it now
May 19th, 2015 10:26pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics