'Full control' but cannot 'publish'?
I've created 4 pages within a folder: /Pages/folder. I've then added 1 user to each page via permissions, to give them 'Full control'. They can go to 'edit page', and they can edit the page, but they cannot publish their edits or even 'check in' the modified page. The only option they have is 'exit edit mode'? I've been going round in circles with this for a week or so now, trying all the different permissions. Is there something I'm missing? Do they need to have Design permission for the whole site to edit a single item/page? Any help much appreciated. Thanks, Andy
November 10th, 2011 5:06am

Hi Andy, is Administrator can able to publish the form, if not than you can go with below approach. The problem is look like that the State service is not configured since the Farm Configuration Wizard has not been run. Configure it with PowerShell using these instructions from Technet: On the Taskbar, click Start, point to Administrative Tools, and then click Windows PowerShell Modules. In Windows PowerShell, create a service application by typing $serviceApp = New-SPStateServiceApplication -Name “State Service” Create a State Service database and associate it with a service application, by typing New-SPStateServiceDatabase -Name ”StateServiceDatabase” -ServiceApplication $serviceApp. Create a State Service Application Proxy and associate it with the service application by typing New-SPStateServiceApplicationProxy -Name ”State Service” -ServiceApplication $serviceApp -DefaultProxyGroup. Once these instructions are run, you have a shiny new State Service Service Application and you should be able to publish pages again. Remember to verify that your web Application is associated with the State Service Service Application. Please run below mention command. $serviceApp = New-SPStateServiceApplication -Name “State Service” New-SPStateServiceDatabase -Name ”StateServiceDatabase” -ServiceApplication $serviceApp New-SPStateServiceApplicationProxy -Name ”State Service” -ServiceApplication $serviceApp -DefaultProxyGroup if it does not solve your porblem reply please. Krishana Kumar http://mosstechnet-kk.com
Free Windows Admin Tool Kit Click here and download it now
November 10th, 2011 6:31am

I think we're on completely different levels here! I'm simply a user of a huge corporate intranet, powered by SharePoint. I am the owner of a 'community site' and so can delegate permissions of the content on my internal site. I have tried to give 'Full control' permission to a single user for a single page, but they cannot save any changes they make. Apologies if this wasn't clear, thanks for your reply.
November 10th, 2011 6:43am

Try giving approval permission in addition to old permission and check ..guess that should work :)
Free Windows Admin Tool Kit Click here and download it now
November 10th, 2011 8:05am

The user has 'Full control' and 'Approve' now but still cannot publish. They get the option to edit the page, but cannot publish it. If I give approval permission to them across the rest of the site then they can edit the whole site - I'd prefer to avoid that if possible?
November 10th, 2011 9:15am

if you Give the users "Approve" permission on the web application using "Web Application Policy's" your issue will be resolve, but you dont want to apply this, so first check that what is the issue is logging in Log file and event vwr, if it is releated to access denied, then we can come up with exact approch.Krishana Kumar http://mosstechnet-kk.com
Free Windows Admin Tool Kit Click here and download it now
November 11th, 2011 2:03am

Hi, Check whether publishing feature is activated? If not activate it and try again. Thanks, Rahul Rashu
November 11th, 2011 3:41am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics