"The request failed with HTTP status 401: Unauthorized."  - SQL Reporting Services
Hi, I have deployed the reports to the report server(centralized server). when i try to access the reports directly thru report server i.e http://servername//ReportServer in my local system. it asks for the username/password, when i give the username and password it accepts and shows me the report. the same report i try to access in .NET Application, i do not know how to pass the credentials and it throws the error :"The request failed with HTTP status 401: Unauthorized ". I am using VS 2005 and SQL Server 2005 and SQL Reporting Services 2005. with regards Suresh Babu
January 30th, 2006 2:31pm

What exactly were you doing when you said "try to acess in .Net application"?
Free Windows Admin Tool Kit Click here and download it now
January 30th, 2006 11:53pm

finally i got it right , but do not whether that is the best way or the only way of solving it. In Report Server Machine , I went to ISS where Reports and ReportServer folders are created and for both reports I selected Access for anonyomous user option in Directory Security tab(Right click on that folder and click on the properties)and gave an username and password which i use to login into that Machine and i unchecked the option Windows integrated Authentication in that same tab. it worked.
February 1st, 2006 7:19am

Can someone reply to this and give a response on if it is the most appropriate way to configure URL access to Reports & ReportServer in a networked environment?
Free Windows Admin Tool Kit Click here and download it now
August 20th, 2007 9:53pm

I went in and created an anonymous option too, and I set only "basic" permissions, PLUS I installed a hotfix. I went from being totally blocked with 401 errors to being able to get to the report manager with password entry and after entering my passwork literally a dozen times over and over again, to be able to see the report services page. However, my install of CRM still blows up on the reporting services bit (probably because it is not able to enter the password an arbitrary, large number of times). I did a huge number of messy changes, most of which I did not even keep exact track, just to get to this stage, so I am still interested in the original question, but also now in this phenomenon which I am encountering, i.e., where I have to type the password over and over to finally get to the report services screen....and my CRM install still blowing up. It seems to me that nobody should be able to install CRM if this is what happens. What could they do?
July 14th, 2008 10:10am

Hi Suresh, this is not proper solution you end up giving access to all the user who use the server. check trhe reports with different logins who is having different roles . You will find same result for all because it filter the record on what user you mentioned in anonyomous access. Therefore you need to added Domain\Iusr_server inanonyomous acces and password should be left blank it will take dummy password and get saved . Regards, Dyaman
Free Windows Admin Tool Kit Click here and download it now
June 10th, 2009 3:19pm

The solution at this link worked for me: http://connect.microsoft.com/SQLServer/feedback/details/323214/the-request-failed-with-http-status-401-unauthorized Mirza
November 29th, 2010 6:39pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics