"Site is in a partially provisioned state" when attaching/upgrading SHP2010 content DB in SHP2013

I'm testing out upgrading our Sharepoint 2010 farm to Sharepoint 2013.

Fortunately for me we have very few specialties in our farm, very straight forward.

But when setting up the new MySites, when I add one of the old content databases (and so far only for this one!) it starts spitting out a few (20 or so) messages about peoples "sites is in a partially provisioned state". The site still works fine after upgrade but I don't like having errors like this so I digged deeper.

Googling didn't help, I only found an article about Sharepoint Online so that wasn't a big help.

But looking into the details in the ULS for these jobs I see the following critical message:
"Unknown SQL Exception 15151 occurred. Additional error information from SQL Server is included below.  Cannot alter the role 'SPDataAccess', because it does not exist or you do not have permission."

I like that error message because at first it seems pretty clear. But unfortunately I'm doing this all with a farm account that is sysadmin on the entire SQL instance, so permissions aren't a problem. But as far as I can see there is no SPDataAccess role on either this instance or the "old" one where this database came from!

I thought about messing in the SQL when I remembered an old quote from my Sharepoint 2010 instructor - "the second you go and edit the SQL yourself you're on your own" so I stopped there.

Any suggestions? A "ignore this error" is pretty much useless since I don't a choice in the matter, but I still want to know what the hell is up with this error?

Kind regards // Kris

February 7th, 2014 1:56pm

Check if self service site collection is enabled in 2013 my site host. Also check for domain name resolution option within Userprofie Service application option. Without configuring these mysite in 2013 is not in completed unlike in 2010. This might be causing issue.
Free Windows Admin Tool Kit Click here and download it now
February 7th, 2014 6:26pm

Hello

This issue is fixed in March PU, are you running RTM by chance?  You really should be at March PU regardless as you cannot patch any further without that in place first.

http://support.microsoft.com/kb/2768000

February 8th, 2014 11:13pm

Yes, I'm running the latest CU (December 2013).

I think I found the issue, but I need to experiment a bit with it to find exactly what permission it is that have been lost.

The issue seems to be that the DB user permissions wasn't set properly on the User Profile databases which showed itself when I tried to "Follow" a site and got a "something went wrong" message. Since it's a test environment I simply added sysadmin permission on the instance to the app pool running the site and it worked fine.

But as I said, I will need to test thing to more specifically say what account needed what permission to solve the issue, as granting sysadmin access isn't viable in a production Environment.

It was probably caused by me removing and recreating both the user profiles and MySite application quite a few times in my test Environment.

Free Windows Admin Tool Kit Click here and download it now
February 9th, 2014 2:18am

you need to add the app pool account of Mysites into User profile adminsitration....No need to add into sysadmin..

from Central Admin > manage services application > User profile ? permission...add over here and then try.

February 9th, 2014 2:41am

Hi All,

This error started occurring after October 2013 CU, the The SP_DATA_ACCESS role replaces the db_owner role in SharePoint 2013.

This should prove interesting as there is split behavior whether you are using PowerShell or the UI... Hmmm

 

Reference

http://technet.microsoft.com/en-us/library/cc678863.aspx#Section4

http://www.mavention.com/blog/october-2013-cu-issue-adding-existing-content-database

Thank you mavention, if you don't read the mavention blog you should..

-Ivan

Free Windows Admin Tool Kit Click here and download it now
February 9th, 2014 3:02am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics